Open Closed

Errors when opening new project in Visual Studio #10299


0
paulg created

I dowloaded and opened ASP.NET CORE & Angular (single solution) with .NET 5.0 and v10.3.0 yesterday. I'm seeing these errors after opening Web.sln:

  • NU1202 Package IdentityServer4 4.1.1 is not compatible with net50 (.NETFramework,Version=v5.0) / win7-x86. Package IdentityServer4 4.1.1 supports: netcoreapp3.1 (.NETCoreApp,Version=v3.1)
  • NU1202 Package IdentityServer4 4.1.1 is not compatible with net50 (.NETFramework,Version=v5.0). Package IdentityServer4 4.1.1 supports: netcoreapp3.1 (.NETCoreApp,Version=v3.1)
  • NU1202 Package IdentityServer4.AccessTokenValidation 3.0.1 is not compatible with net50 (.NETFramework,Version=v5.0) / win7-x86. Package IdentityServer4.AccessTokenValidation 3.0.1 supports: netcoreapp3.0 (.NETCoreApp,Version=v3.0)
  • NU1202 Package IdentityServer4.AspNetIdentity 4.1.1 is not compatible with net50 (.NETFramework,Version=v5.0) / win7-x86. Package IdentityServer4.AspNetIdentity 4.1.1 supports: netcoreapp3.1 (.NETCoreApp,Version=v3.1)
  • MSB3644 The reference assemblies for framework ".NETFramework,Version=v5.0" were not found. To resolve this, install the SDK or Targeting Pack for this framework version or retarget your application to a version of the framework for which you have the SDK or Targeting Pack installed. Note that assemblies will be resolved from the Global Assembly Cache (GAC) and will be used in place of reference assemblies. Therefore your assembly may not be correctly targeted for the framework you intend.

.Net should be installed: C:\WINDOWS\system32>dotnet --list-sdks 2.1.403 [C:\Program Files\dotnet\sdk] 2.1.502 [C:\Program Files\dotnet\sdk] 2.2.101 [C:\Program Files\dotnet\sdk] 5.0.202 [C:\Program Files\dotnet\sdk]

Please let me know what could be wrong.


1 Answer(s)
  • 0
    paulg created

    This was resolved by installing VS 2019, from VS 2017.