Open Closed

RAD tool doesn't appear to set primengTableHelper.defaultRecordsCountPerPage correctly. #7479


0
rickfrankel created

Hi,

When using the RAD tool to generate UI for entities. The paging on the UI doesn't appear to work correctly.

ASP.NET CORE & Angular .NET Core 2.2 v7.1.0

It appears as tho the rows value is hard coded to 5. I've tried all sorts of methods to try and change it, but not having a lot of luck.

I've changed the rows= value in two spots in the html files and remove the hard coded setting of it to 5 in the .ts files.

Am I missing something? I want a default page size of 100. I've set this up and all existing pages are working fine, however any newly created ones with the RAD tool do not work.

Thanks Rick


2 Answer(s)
  • 0
    yekalkan created

    Hi,

    Thanks for reporting. rows attribte should be [rows] in p-paginator tag. We'll fix this in next version.

    For you problem, You can do the following changes:

    1. change rows="{{primengTableHelper.defaultRecordsCountPerPage}}" to [rows]="100" in *.html file.

    2. add this method to your *.ts file: ngOnInit(): void { this.paginator.rows = 100; }

  • 0
    rickfrankel created

    [rows] is the answer. That was what caused the issue.

    Thanks