Open Closed

Login redirected back to Login page when hosted on Azure Linux based wepapp #10596


0
admin@syntaq created

Prerequisites

Please answer the following questions before submitting an issue. YOU MAY DELETE THE PREREQUISITES SECTION.

  • What is your product version? 8.8
  • What is your product type (Angular or MVC)? MVC
  • What is product framework type (.net framework or .net core)? .Net Core 3.1

After atempting logging in the user is directed back to the login page with no error message (or error in audit log)

Please NOTE We have two instances of identical code base. One is deployed to an Azure hosted windows based web app the second to an Azure hosted Windows based web app. The windows based web app logs on normally, the linux based web app **does not ** logon (The login screen shows and the swagger UI seems to function as expected)


6 Answer(s)
  • 0
    ismcagdas created
    Support Team

    Hi admin@syntaq

    Can you login as a host user ? If not, can you share your app's URL with info@aspnetzero.com ?

    Thanks,

  • 0
    admin@syntaq created

    Hi,

    We cannot login as Host. The url has been emaile dto info@aspnetzero.com

    Cheers

  • 0
    admin@syntaq created

    Hi,

    Updating this issue again. Have emailed login URL and details to info@aspnetzero.com as requested above.

    FYI. This is hosted on an Azure Linux based Web App (the Windows based Web app runs with no problem)

    Thanks

  • 0
    admin@syntaq created

    Further Audit trail information

    Id BrowserInfo ClientIpAddress ClientName CustomData Exception ExecutionDuration ExecutionTime ImpersonatorTenantId ImpersonatorUserId MethodName Parameters ServiceName TenantId UserId ReturnValue 105 Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36 Edg/95.0.1020.53 ::ffff:172.16.1.1 NULL NULL NULL 145 34:10.7 NULL NULL Login {"loginModel":{"rememberMe":false,"usernameOrEmailAddress":"admin"},"returnUrl":"/Falcon","returnUrlHash":null,"ss":null} Syntaq.Falcon.Web.Controllers.AccountController NULL NULL NULL 106 Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36 Edg/95.0.1020.53 ::ffff:172.16.1.1 NULL NULL NULL 1 34:11.1 NULL NULL Login {"returnUrl":"/Falcon"} Syntaq.Falcon.Web.Controllers.AccountController NULL NULL NULL

  • 0
    ismcagdas created
    Support Team

    Hi,

    Sorry for the delay, we have replied you via email.

  • 0
    admin@syntaq created

    Hi,

    We responded to the last email two days ago. Can you try accessing the link provided again.