Open Closed

TypeScript Virtual Projects errors #3451


0
michaelhilgers created

Hi,

I have a lot of error messages in Visual Studio. All errors come from TypeScript Virtual Projects.

I would like using my project on a new installed pc. Visual Studio 2015 Update 3

I installed globaly: node v6.9.5 , npm 5.0.3 angular-cli:1.0.0-rc.0 For the project there is Node : v6.9.5, npm : 3.10.10, TypeScript : 2.0.8 angular cli : 1.0.0-rc.0 installed

package.json :

{
  "name": "abp-zero-template",
  "version": "0.0.0",
  "license": "MIT",
  "angular-cli": {},
  "scripts": {
    "ng": "ng",
    "start": "ng serve --host 0.0.0.0 --port 4200 --live-reload-port 4201",
    "hmr": "ng serve --host 0.0.0.0 --port 4200 --live-reload-port 4201 --hmr -e=hmr",
    "test": "ng test",
    "pree2e": "webdriver-manager update --standalone false --gecko false",
    "e2e": "protractor"
  },
  "private": true,
  "dependencies": {
    "@angular/cli": "1.0.0-rc.0",
    "@angular/common": "~2.4.0",
    "@angular/compiler": "~2.4.0",
    "@angular/core": "~2.4.0",
    "@angular/forms": "~2.4.0",
    "@angular/http": "~2.4.0",
    "@angular/platform-browser": "~2.4.0",
    "@angular/platform-browser-dynamic": "~2.4.0",
    "@angular/router": "~3.4.0",
    "@types/bootstrap": "^3.3.32",
    "@types/bootstrap-datepicker": "0.0.6",
    "@types/jquery": "^2.0.33",
    "@types/jquery.blockui": "0.0.27",
    "@types/jstree": "^3.3.32",
    "@types/lodash": "^4.14.37",
    "@types/moment": "^2.13.0",
    "@types/moment-timezone": "^0.2.32",
    "@types/node": "^6.0.42",
    "@types/select2": "^4.0.34",
    "@types/signalr": "^2.2.32",
    "@types/toastr": "^2.1.32",
    "abp-ng2-module": "^0.2.1",
    "abp-web-resources": "^1.3.0",
    "block-ui": "^2.70.1",
    "bootstrap": "^3.3.7",
    "bootstrap-colorpicker": "^2.5.1",
    "bootstrap-datepicker": "^1.6.4",
    "bootstrap-daterangepicker": "^2.1.24",
    "bootstrap-select": "^1.11.2",
    "bootstrap-switch": "^3.3.2",
    "core-js": "^2.4.1",
    "famfamfam-flags": "^1.0.0",
    "font-awesome": "^4.6.3",
    "jquery": "3.1.1",
    "jquery-migrate": "^3.0.0",
    "jquery-slimscroll": "^1.3.8",
    "jquery-sparkline": "^2.4.0",
    "jquery.uniform": "^4.0.1",
    "jqueryui": "^1.11.1",
    "js-cookie": "^2.1.3",
    "jstree": "^3.3.2",
    "jtable": "^2.4.1",
    "localforage": "^1.4.3",
    "lodash": "^4.16.4",
    "moment": "^2.15.1",
    "moment-timezone": "^0.5.7",
    "morris.js": "^0.5.0",
    "ng2-bootstrap": "^1.1.16-11",
    "ng2-file-upload": "^1.1.4-2",
    "ng2-recaptcha": "^1.4.0",
    "raphael": "^2.2.7",
    "rtl-detect": "^1.0.0",
    "rxjs": "^5.0.1",
    "select2": "^4.0.3",
    "select2-bootstrap-theme": "^0.1.0-beta.10",
    "signalr": "^2.2.1",
    "simple-line-icons": "^2.4.1",
    "spin.js": "^2.3.2",
    "sweetalert": "^1.1.3",
    "timeago": "^1.5.3",
    "toastr": "^2.1.2",
    "ts-helpers": "^1.1.1",
    "zone.js": "^0.7.4",
    "timepicker": "^1.11.9",
    "ng2-cache": "^0.1.11"
  },
  "devDependencies": {
    "@angular/cli": "^1.0.0-rc.0",
    "@angular/compiler-cli": "^2.3.1",
    "@angularclass/hmr": "^1.2.2",
    "@types/grecaptcha": "^2.0.30",
    "@types/jasmine": "^2.2.30",
    "@types/morris.js": "^0.5.5",
    "@types/node": "^6.0.42",
    "codelyzer": "~2.0.0-beta.4",
    "jasmine-core": "2.5.2",
    "jasmine-spec-reporter": "2.7.0",
    "karma": "1.3.0",
    "karma-chrome-launcher": "^2.0.0",
    "karma-cli": "^1.0.1",
    "karma-jasmine": "^1.0.2",
    "karma-remap-istanbul": "^0.3.2",
    "nswag": "^8.1.0",
    "protractor": "4.0.14",
    "ts-node": "1.7.2",
    "tslint": "^4.3.0",
    "typescript": "2.0.8"
  }
}

For some errors please see the picture...

Do you have an idea where the error comes from ?

Thanks !


3 Answer(s)
  • 0
    ismcagdas created
    Support Team

    Hi,

    As I remember, we have faced a similar problem and it was related to "extends" property of this config file <a class="postlink" href="https://github.com/aspnetzero/aspnet-zero-core/blob/dev/angular/e2e/tsconfig.json">https://github.com/aspnetzero/aspnet-ze ... onfig.json</a>.

    Can you compare it with yours.

    Thanks.

  • 0
    michaelhilgers created

    Hi,

    My tsconfig.json looks like this :

    {
      "compileOnSave": false,
      "compilerOptions": {
        "declaration": false,
        "emitDecoratorMetadata": true,
        "experimentalDecorators": true,
        "module": "commonjs",
        "moduleResolution": "node",
        "outDir": "../dist/out-tsc-e2e",
        "sourceMap": true,
        "target": "es5",
        "typeRoots": [
          "../node_modules/@types"
        ]
      }
    }
    

    But event if I replace my config with the suggested config it doesn't work.

  • 0
    ismcagdas created
    Support Team

    Can you try to upgrade typescript on your computer, it might be related to that.

    By the way, I just realized that you are using VS 2015, you should try it with VS 2017. If upgrading typescript does not work, can you try it with VS 2017 and share the result ?

    Thanks.