Open Closed

How to Enable and Disable Re-captcha ? #3455


0
shanefryer4184 created

I have Angular 4 with Asp.net Core.

I have build and deployed the app on Azure. Now I am getting "Error for site owner. Invalid domain for site key"

I have created new Site key & secret key from google captcha and replace it in Appsettings.json under the Core Layer.

But still I am not getting the captcha check box like it should be.

I even disabled it from the tenant settings under user management, but no use.

If it is a bug, how should I disable captcha?

Hope to hear from you soon.


5 Answer(s)
  • 0
    ismcagdas created

    Hi,

    In Angular4 version, you need to set recaptcha site key here https://github.com/aspnetzero/aspnet-ze ... onfig.json.

    Also, you should create key for angular client site app.

    Thanks.

  • 0
    shanefryer4184 created

    The link you have sent me is not working.

    I already set site and secret key in appsettings.json in Dotnet core folder

    In Angular folder, appconfig.json has no value for sitekey. Should I add sitetkey just the way it is in appsettings.json ?

    What do you mean by "create key for angular client site app." ? Can you elaborate ?

  • 0
    ismcagdas created

    Hi,

    If your setting file for angular does not contain that key, you can check register.component.html and register-tenant.component.html.

    We moved this setting to appconfig.json but it was embedded in html files in one of previous versions.

    You also need to create a recaptcha key here https://www.google.com/recaptcha/admin#list for your domain.

    If you can also share your github username, we can invite you to aspnetzero organization, so you can see private repositories.

    Thanks.

  • 0
    shanefryer4184 created
  • 0
    ismcagdas created

    Hi,

    You are invited on github. We also have https://github.com/ShaneFryer4184 as your other github account, do you use both accounts ?

    Thanks.