Black Friday Sale!
Save up to 50% off any plans! Valid from 23 Nov to 30 Nov - Also valid for the existing customers
Open Closed

Error Loading Site and unable to debug #3522


0
patrickparker created

I've ran the migration database utility I have it to a point where the site loads, shows a spinner, then gives an error "An error has occurred, Error detail not sent by server"

How do I get this error? How do I attach to the process to step through it? I attempted to attach to the node.exe process' with no luck. I've tried to use ng build, then point an iis application to the dist folder(after moving the webconfig there), gives an error saying service unavailable.

Any help would be appreciated

Thanks Rick


11 Answer(s)
  • 0
    alper created
    Support Team

    hi

    which version are you using?

  • 0
    patrickparker created

    I am using the .net core with angular v4

  • 0
    ismcagdas created
    Support Team

    Hi @PatrickParker,

    Problem might be related to both *.Web.Host project and angular project. You can check Logs.txt for error details. It is placed under Web.Host project.

    You can also check browser's javascript console to see error on angular side.

    If both does not work, can you share a screenshot of your browser's javascript console ?

    Thanks.

  • 0
    patrickparker created

    Here is the Console output

    Navigated to <a class="postlink" href="http://localhost:4200/">http://localhost:4200/</a> VM56:2 JQMIGRATE: Migrate is installed, version 3.0.0 zone.js:2176 OPTIONS <a class="postlink" href="http://localhost:22742/AbpUserConfiguration/GetAll">http://localhost:22742/AbpUserConfiguration/GetAll</a> net::ERR_CONNECTION_REFUSED

  • 0
    ismcagdas created
    Support Team

    Hi,

    Are you running *.Web.Host project at the same time ?

    Thanks.

  • 0
    patrickparker created

    I am trying to follow your instructions but they seem incomplete for the combined solution.

    They state "Locate to the Client folder, open a command line and run the following command to restore packages:"

    There is no "client" folder, I am running the combined solution and using npm start on the Web.Host project.

    When I try to use the separate solution instead I get the error "@angular/compiler-cli was not properly installed" when I try to run npm start on the "angular" folder(I have installed angular cli multiple times and run angular install on the folder).

  • 0
    ismcagdas created
    Support Team

    Hi,

    Sorry for the document mistake. It should be angular folder instead of client. I have fixed it. So, have you installed node packages using yarn comand to run angular app ? It is the first step for running angular app.

    Also, before running angular app, you must run host application first.

    Normally we don't offer remote support but since you are having problems running AspNet Zero for the first time. If you still have problems running it, we can assist you remotely. We can make a team viewer connection to your computer and run your application for the first time.

  • 0
    patrickparker created

    Yes I have installed and run yarn. And yes I am running the host project separating. How do I schedule a teamviewer session?

    Here is my command history

    Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\rick.PROD\Documents\code\angular\angular>yarn yarn install v0.27.5 warning package.json: "dependencies" has dependency "@types/jasmine" with range "^2.5.47" that collides with a dependency in "devDependencies" of the same name with version "^2.5.38" warning package.json: "dependencies" has dependency "@types/node" with range "^6 .0.42" that collides with a dependency in "devDependencies" of the same name wit h version "^6.0.69" warning package.json: "dependencies" has dependency "codelyzer" with range "^2.1 .1" that collides with a dependency in "devDependencies" of the same name with v ersion "^2.0.1" warning package.json: "dependencies" has dependency "jasmine-spec-reporter" with range "^3.3.0" that collides with a dependency in "devDependencies" of the same name with version "^3.2.0" warning package.json: "dependencies" has dependency "karma" with range "^1.6.0" that collides with a dependency in "devDependencies" of the same name with versi on "^1.4.1" warning package.json: "dependencies" has dependency "ts-node" with range "^1.7.3 " that collides with a dependency in "devDependencies" of the same name with ver sion "^1.7.2" warning abp-zero-template@4.0.0: "dependencies" has dependency "@types/jasmine" with range "^2.5.47" that collides with a dependency in "devDependencies" of the same name with version "^2.5.38" warning abp-zero-template@4.0.0: "dependencies" has dependency "@types/node" wit h range "^6.0.42" that collides with a dependency in "devDependencies" of the sa me name with version "^6.0.69" warning abp-zero-template@4.0.0: "dependencies" has dependency "codelyzer" with range "^2.1.1" that collides with a dependency in "devDependencies" of the same name with version "^2.0.1" warning abp-zero-template@4.0.0: "dependencies" has dependency "jasmine-spec-rep orter" with range "^3.3.0" that collides with a dependency in "devDependencies" of the same name with version "^3.2.0" warning abp-zero-template@4.0.0: "dependencies" has dependency "karma" with rang e "^1.6.0" that collides with a dependency in "devDependencies" of the same name with version "^1.4.1" warning abp-zero-template@4.0.0: "dependencies" has dependency "ts-node" with ra nge "^1.7.3" that collides with a dependency in "devDependencies" of the same na me with version "^1.7.2" [1/4] Resolving packages... [2/4] Fetching packages... error @angular/cli@1.1.3: The engine "node" is incompatible with this module. Ex pected version ">= 6.9.0". error Found incompatible module info Visit <a class="postlink" href="https://yarnpkg.com/en/docs/cli/install">https://yarnpkg.com/en/docs/cli/install</a> for documentation about this command.

    C:\Users\rick.PROD\Documents\code\angular\angular>npm start

    abp-zero-template@4.0.0 start C:\Users\rick.PROD\Documents\code\angular\angula r ng serve --host 0.0.0.0 --port 4200

    You are running version 6.3.1 of Node, which will not be supported in future versions of the CLI. The official Node version that will be supported is 6.9 and greater.

    To disable this warning use "ng set --global warnings.nodeDeprecation=false".The "@angular/compiler-cli" package was not properly installed. Error: The "@angular/compiler-cli" package was not properly installed. at Object.<anonymous> (C:\Users\rick.PROD\Documents\code\angular\angular\nod e_modules@ngtools\webpack\src\index.js:14:11) at Module._compile (module.js:541:32) at Object.Module._extensions..js (module.js:550:10) at Module.load (module.js:458:32) at tryModuleLoad (module.js:417:12) at Function.Module._load (module.js:409:3) at Module.require (module.js:468:17) at require (internal/module.js:20:19) at Object.<anonymous> (C:\Users\rick.PROD\Documents\code\angular\angular\nod e_modules@angular\cli\tasks\eject.js:10:19) at Module._compile (module.js:541:32) at Object.Module._extensions..js (module.js:550:10) at Module.load (module.js:458:32) at tryModuleLoad (module.js:417:12) at Function.Module._load (module.js:409:3) at Module.require (module.js:468:17) at require (internal/module.js:20:19) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! abp-zero-template@4.0.0 start: ng serve --host 0.0.0.0 --port 4200 npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the abp-zero-template@4.0.0 start script. npm ERR! This is probably not a problem with npm. There is likely additional log ging output above.

    ?─────────────────────────────────────? │ │ │ Update available 5.0.4 → 5.3.0 │ │ Run npm i -g npm to update │ │ │ ?─────────────────────────────────────?

    npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\rick.PROD\AppData\Roaming\npm-cache_logs\2017-07-20T03_45 _20_765Z-debug.log

    C:\Users\rick.PROD\Documents\code\angular\angular>

  • 0
    ismcagdas created
    Support Team

    Hi,

    According to logs, you are using an old version of node. Can you try to install node 6.9 or above version and try this again ?

    If that does not work, please send an email to <a href="mailto:info@aspnetzero.com">info@aspnetzero.com</a> and we will schedule a meeting time.

    Thanks.

  • 0
    patrickparker created

    That worked, but I am still having a problem hosting the site in IIS. I execute ng build, it creates a "dist" folder, then I make an IIS application and point the application to the dist folder. But I get a Service Unavailable when I try to hit the index.html page in the dist folder. What else do I need to do to get this to work in IIS?

    Rick

  • 0
    ismcagdas created
    Support Team

    Hi @PatrickParker,

    Angular client contains only html/js/css files. You should at least be able to see a basic html file.

    Can you host a simple html file on your IIS (not related to ) ?