Open Closed

Problem publish to local IIS for testing #7139


0
rnguyen created

Hi,

I am using latest source code V7.0 - Jquery .Net Core - VS 2019

I follow your instruction to publish a web site but not able to launch. Please help

https://docs.aspnetzero.com/documents/aspnet-core-angular/latest/Deployment-Angular-Publish-IIS

image.png

image.png

image.png

image.png

Thank you


6 Answer(s)
  • 0
    maliming created

    You can look at the log information based on Application Event Log and ASP.NET Core Module stdout log.

    https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/troubleshoot?view=aspnetcore-2.2#application-event-log

    https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/iis/troubleshoot?view=aspnetcore-2.2#aspnet-core-module-stdout-log

  • 0
    rnguyen created

    i'm still not able to resolve this issue. please help remote into my machine

    thx

  • 0
    maliming created

    Please send your teamviewer information to liming.ma@volosoft.com

  • 0
    quantavn created

    I've had an isse with Local IIS Deployment too. I'm using ASP.NET Core & Angular (v7.0.0). I can deploy and open both the Host and the Web. But whenever I click on the flag to switch to another localization: image.png I got an 'HTTP Error 404.0 - Not Found': image.png Press F5 to refresh is no help. I can only open the Web again if I change the URL from: 'http://localhost:8080/app/admin/hostDashboard' to 'http://localhost:8080/' then click Enter: image.png

  • 0
    maliming created

    Solved by remote.

  • 0
    rnguyen created

    Great help!

    1. install dotnet-hosting-2.2.5-win https://dotnet.microsoft.com/download/thank-you/dotnet-runtime-2.2.5-windows-hosting-bundle-installer

    2. update web.config and make sure create a folder in the root for .\logs\stdout

    3. Run this first image.png

    4. If run on local PC add domain name to the host file

      image.png

      image.png

      image.png

        <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <system.webServer>
        <handlers>
          <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModuleV2" resourceType="Unspecified" />
        </handlers>
        <aspNetCore processPath="%LAUNCHER_PATH%" arguments="%LAUNCHER_ARGS%" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" forwardWindowsAuthToken="false" startupTimeLimit="3600" requestTimeout="23:00:00">
          <environmentVariables />
        </aspNetCore>
        <httpProtocol>
          <customHeaders>
            <remove name="X-Powered-By" />
          </customHeaders>
        </httpProtocol>
      </system.webServer>
    </configuration>
    
    

    to view error

    image.png