Open Closed

My Screen goes blank when I tried to add <Form> tag on newly created page (Angular + .Net Core) #8519


0
optixdev created

My Screen goes blank and url navigate to "http://localhost:4200/" when I tried to add Form> tag on newly created page (Angular + .Net Core)


10 Answer(s)
  • 0
    optixdev created

  • 0
    maliming created
    Support Team

    Is there an error in the browser console?

  • 0
    optixdev created

  • 0
    bobingham created

    HI @optixdev, Follow the instructions for angular reactive forms, in your case I don't think you have imported the ReactiveFormsModule to your module:

      imports: [
        FormsModule,
        ReactiveFormsModule,
    

    Hope that helps.

  • 0
    optixdev created

    I am still facing the problem: I use the basic reactive form example from the - https://www.techiediaries.com/build-angular-form/ I already did the necessary changes to app module file.

  • -1
    bobingham created

    @optixdev, I feel for you, you are obviously at the bottom of a steep learning curve! Your problem is not Zero related but angular related, google "angular can't bind to 'formgroup' since it isn't a known property of 'form'" and you will find your answer amongst 3,000 choices: Can't bind to 'formGroup' since it isn't a known property of 'form' Good luck!!

  • 0
    optixdev created

    @bobingham same Angular code is running on the another application but its not running on the Zero, hope you understand.

  • -1
    bobingham created

    Not a problem, check your module declarations in your other project, it's obviously an import issue. Glad to help if I can but I think with a little more perserverance you'll find the issue here.

  • 0
    optixdev created

    import { FormsModule, ReactiveFormsModule } from '@angular/forms';

    imports: [ FormsModule, BrowserModule, ReactiveFormsModule ],

  • 0
    bobingham created

    See above, first answer!!!!