Open Closed

appBaseUrl setting alters page formatting #10257


0
timmackey created

ANZ 8.1.0 angular/.net core

When appconfig.json and appconfig.Production.json are set to "appBaseUrl": "https://mydomain-dev-client.azurewebsites.net" the login screen displays normally.

When the .json files are set to "appBaseUrl": "https://mydomain.com/" the login screen does not display correctly, and the site is "Not secure".


9 Answer(s)
  • 0
    ismcagdas created
    Support Team

    Hi,

    Is your site mydomain.com have a valid SSL certificate ?

    Thanks,

  • 0
    timmackey created

    Yes. Please notice the black lock icon visible in the first screenshot. Domain name sent to info@aspnetzero.com.

  • 0
    ismcagdas created
    Support Team

    Hi @timmackey

    Thanks. I think this happens because some styles can't be loaded when you use mydomain.com as appBaseUrl. Are both URLs pointing the same app ? When I ping both URLs, they are showing different URLs. Probably where the mydomain.com is placed, these styles fiels doesn't exist.

    Could you be sure for example "assets/metronic/themes/default/css/style.bundle.min.css" exists in where mydomain.com placed.

    Thanks,

  • 0
    timmackey created

    style.bundl.min.css has different contents, depending on the setting in appBaseUrl.

    Screenshots sent to email@aspnetzero.com Subject: Re: appBaseUrl setting alters page format... (#10257)

  • 0
    timmackey created

    project files emailed to info@aspnetzero.com

  • 0
    ismcagdas created
    Support Team

    Hi @timmackey

    We haven't received the files. Could you send it again ?

    Thanks,

  • 0
    timmackey created

    Sent 2nd time. Email contains link to 78MB zip file on Google Drive.

  • 0
    ismcagdas created
    Support Team

    Hi @timmackey

    Thanks, we got the project this time and will check it.

    Thanks,

  • 0
    timmackey created

    This was caused by an invalid domain forwarding configruation error. Specifically, when Godaddy is the domain name registrar, and Azure is the host provider, you must use an A record with the Azure host IP address, and NOT the "Forwarding" setup in Godaddy.