Open Closed

Problems building stock solution #4544


0
easyest created

Downloaded stock solution: [attachment=2:mjlmeyph]1 download.png[/attachment:mjlmeyph] 1st build: [attachment=1:mjlmeyph]2 error1.png[/attachment:mjlmeyph] Maybe this is because of references: [attachment=0:mjlmeyph]3 assemblies.png[/attachment:mjlmeyph]


8 Answer(s)
  • 0
    easyest created

    OK, this can be fixed with package install: [attachment=2:1xninr6t]4 package.png[/attachment:1xninr6t] Now Core.Shared is building. Now Application.Shared is giving some erorrs: [attachment=1:1xninr6t]5 error2.png[/attachment:1xninr6t] Maybe this something to do with the target framework? [attachment=0:1xninr6t]6 target framework.png[/attachment:1xninr6t]

  • 0
    easyest created

    I tried "dotnet restore", I tried repairing Visual Studio, nothing helps. I have almost every .NET component installed: [attachment=0:kf5gpw4b]7 components 1.png[/attachment:kf5gpw4b]

    Tried the same on another PC with full VS2017 install - same problems.

  • 0
    aaron created
    Support Team

    Did you install .NET Core 2.0 SDK?

  • 0
    ismcagdas created
    Support Team

    @easyest Also Visual Studio 2017 v15.3+ is required.

  • 0
    easyest created

    Visual Studio 15.5.4 installed. No additional SDK/framework installed, but .NET Core 2 should be already available in VS2017[attachment=0:1ofj6med]8 dot.net.png[/attachment:1ofj6med]

  • 0
    ismcagdas created
    Support Team

    You can cehck it under C:\Program Files (x86)\dotnet\sdk. Here is mine;

  • 0
    easyest created

    After a full PC reinstall and fresh VS2017 install the solution building is successful. But while building Application.Shared and Core.Shared there is a warning:

    C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\15.0\Bin\Microsoft.Common.CurrentVersion.targets(2041,5): warning MSB3245: Could not resolve this reference. Could not locate the assembly "System.ComponentModel.DataAnnotations". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors.

    I removed that reference, and this warning is gone.

  • 0
    ismcagdas created
    Support Team

    Thanks for your feedback @easyest.