Open Closed

access to docker images #9640


0
sedulen created

is there a process for requesting access to the zero/... Docker images?

I am experimenting with using the Docker functionality in ASP.NET Zero (I'm on v6.9, but it looks like the build & docker scripts in v9.0 are similar).

when I run the build script I encounter the following: Error: No such image: zero/host Sending build context to Docker daemon 467MB Error response from daemon: the Dockerfile (Dockerfile) cannot be empty Error: No such image: zero/ng Sending build context to Docker daemon 225.3MB Error response from daemon: the Dockerfile (Dockerfile) cannot be empty and when I run the up script that is in the build/outputs directory, I encounter the following: `Pulling zero_host (zero/host:)... ERROR: The image for the service you're trying to recreate has been removed. If you continue, volume data could be lost. Consider backing up your data before continuing.

Continue with the new image? [yN]y Pulling zero_host (zero/host:)... ERROR: pull access denied for zero/host, repository does not exist or may require 'docker login': denied: requested access to the resource is denied`

thanks! -Brian


2 Answer(s)
  • 0
    sedulen created

    I think I see the issue. In my .Host project, my Dockerfile looks different from what I see when I look back at my base 6.9.0 project. So I may be causing my own issue here. I think I attempted to work with the Dockerfile a few months back and may have inadvertently made some changes. I will look back at my revision history to see if I accidentally changed anything in the default template regarding Docker.

  • 0
    sedulen created

    It appears that was, indeed, my issue.

    I had previously modified the Dockerfile at the root of the .Host project to try and make it fully contained, rather than using the build scripts that were provided as part of the template.

    To note, the only change I found I had to make was in the build-with-ng.ps1 script, the following line seems to give me issue:

    Copy-Item (Join-Path $ngFolder "dist") (Join-Path $outputFolder "ng/") -Recurse

    When I look at my angular.json file, I see:

      "architect": {
        "build": {
          "builder": "@angular-devkit/build-angular:browser",
          "options": {
            "outputPath": "wwwroot/dist",
    

    So if I change that Copy-Item line to be: Copy-Item (Join-Path $ngFolder "wwwroot/dist") (Join-Path $outputFolder "ng/") -Recurse

    the build scripts work for me.