Open Closed

Power Tool stopped working #9604


0
dougmorato created

Prerequisites

Please answer the following questions before submitting an issue. YOU MAY DELETE THE PREREQUISITES SECTION.

  • What is your product version?
  • v9.10
  • What is your product type (Angular or MVC)?
  • angular
  • What is product framework type (.net framework or .net core)?
  • ,net core

I have generated multiple screens using the Visual Studio Extension Aspnetzero power tool. But suddenly it stopped working.

I have uninstalled and installed the RAD tool. I have recreated my code repo. But it not at all working. After creating generate button it closes automatically after few seconds.

Please guide us to troubleshoot and fix this issue.


12 Answer(s)
  • 0
    Mitch created

    Same here Doug.

    The Power Tools window just closes.

    I was initially using it to "Load Entity from Database" but when that wasn't working I tried to create a simple Entity with a single Property and that failed too!

  • 0
    ismcagdas created
    Support Team

    Hi,

    Could you check the Power Tools logs and Windows event viewer logs to see if there are any error messages ?

  • 0
    dparizek created

    I have same problem... one error I am seeing is I get that it cannot access the configuration file - that it is in use by another process.. specifically System.Configuration.ConfigurationManager.dll in the AspNetZeroRadTool folder

  • 0
    AuroraBMS created

    Getting same issue, no errors in Windows event viewer.

    Is it possible to revert back to a lower version while this is being resovlved? Had to reimplement my environment due to crash and unfortunately it installed the latest version and now I am stuck.

  • 0
    dparizek created

    Seconded on is it possible to revert to older versions of Power Tools somehow? My projects on hold pending resolution here.

  • 0
    Mitch created

    This was happening to me, I was advised by ydyazilim to do the following which fixed my issue :-

    Download dotnet-runtime-2.2.0-win-x64.exe

    run on cmd repos\test\aspnet-core\AspNetZeroRadTool dotnet AspNetZeroRadTool.dll ContentFeatures.ContentMenu.json or reinstall power tool.

  • 0
    ismcagdas created
    Support Team

    Hi @Mitch

    Thanks for the feedback. As I can see, target framework of the Power tools is changed. I think it is updated by the code editor accidentally. I'm happy that this solution worked for you.

    @dparizek, @AuroraBMS, @dougmorato

    Could you also try the same.

    Thanks,

  • 0
    dparizek created

    I am confused on directions from Mitch. Currently Aspnetzero Angular solution is using .NET Core 3.1.

    I cannot find 2.2.0 even available for download... where did folks download from?

    Then it says run on cmd (I assume run on the cmd line... or reinstall power tools.. so if we reinstall power tools we can ignore need to run that line?

    If we install 2.2 then do we need to go back to installing 3.1 for the angular/core solution overall?

  • 0
    AuroraBMS created

    @dparizek open powershell and run this command "dotnet-runtime-2.2.0-win-x64.exe"

    In visual studio, uninstall powertools then reinstall power tools.

    This should resolve it for you - resolved it on my side.

    It might require Ef core to be installed/upgraded as well which was also an issue on my side.

  • 0
    Jorahealth created

    My team is getting the same issue, we were able to genertate entities till recently but since we upgraded to powertools to latest, unable to do so, we use .net core 3.1 framework, the above steps did not work.

    This is the log I have....

    DEBUG 2020-09-16 10:33:01,407 [1 ] lVisualStudioExtension.AspNetZeroRadTool - Menu item clicked with params > loadFromJson: False, loadFromDatabase: False, showAboutForm: False ERROR 2020-09-16 10:37:04,432 [1 ] ToolVisualStudioExtension.Helpers.Logger - ForeignKeySelectionForm > cbEntitySelector_SelectedIndexChanged throws exception System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectedIndex at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value) at AspNetZeroRadToolVisualStudioExtension.Dialogs.ForeignKeySelectionForm.cbEntitySelector_SelectedIndexChanged(Object sender, EventArgs e) in D:\github\aspnet-zero-rad\AspNetZeroRadToolVisualStudioExtension\AspNetZeroRadToolVisualStudioExtension\Dialogs\ForeignKeySelectionForm.cs:line 169 ERROR 2020-09-16 10:37:32,712 [1 ] ToolVisualStudioExtension.Helpers.Logger - ForeignKeySelectionForm > cbEntitySelector_SelectedIndexChanged throws exception System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectedIndex at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value) at AspNetZeroRadToolVisualStudioExtension.Dialogs.ForeignKeySelectionForm.cbEntitySelector_SelectedIndexChanged(Object sender, EventArgs e) in D:\github\aspnet-zero-rad\AspNetZeroRadToolVisualStudioExtension\AspNetZeroRadToolVisualStudioExtension\Dialogs\ForeignKeySelectionForm.cs:line 169 ERROR 2020-09-16 10:37:39,639 [1 ] ToolVisualStudioExtension.Helpers.Logger - ForeignKeySelectionForm > cbEntitySelector_SelectedIndexChanged throws exception System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectedIndex at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value) at AspNetZeroRadToolVisualStudioExtension.Dialogs.ForeignKeySelectionForm.cbEntitySelector_SelectedIndexChanged(Object sender, EventArgs e) in D:\github\aspnet-zero-rad\AspNetZeroRadToolVisualStudioExtension\AspNetZeroRadToolVisualStudioExtension\Dialogs\ForeignKeySelectionForm.cs:line 169 ERROR 2020-09-16 10:37:45,567 [1 ] ToolVisualStudioExtension.Helpers.Logger - ForeignKeySelectionForm > cbEntitySelector_SelectedIndexChanged throws exception System.ArgumentOutOfRangeException: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'. Parameter name: SelectedIndex at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value) at AspNetZeroRadToolVisualStudioExtension.Dialogs.ForeignKeySelectionForm.cbEntitySelector_SelectedIndexChanged(Object sender, EventArgs e) in D:\github\aspnet-zero-rad\AspNetZeroRadToolVisualStudioExtension\AspNetZeroRadToolVisualStudioExtension\Dialogs\ForeignKeySelectionForm.cs:line 169 DEBUG 2020-09-16 10:38:59,038 [1 ] dioExtension.Dialogs.EntityGeneratorForm - Generate entity started. DEBUG 2020-09-16 10:38:59,558 [1 ] dioExtension.Dialogs.EntityGeneratorForm - Entity successfully generated. DEBUG 2020-09-16 10:43:31,722 [1 ] lVisualStudioExtension.AspNetZeroRadTool - Menu item clicked with params > loadFromJson: False, loadFromDatabase: False, showAboutForm: False DEBUG 2020-09-16 10:45:09,837 [1 ] dioExtension.Dialogs.EntityGeneratorForm - Generate entity started. DEBUG 2020-09-16 10:45:10,244 [1 ] dioExtension.Dialogs.EntityGeneratorForm - Entity successfully generated. DEBUG 2020-09-16 13:21:50,019 [1 ] lVisualStudioExtension.AspNetZeroRadTool - Menu item clicked with params > loadFromJson: False, loadFromDatabase: False, showAboutForm: True DEBUG 2020-09-16 13:27:06,055 [1 ] lVisualStudioExtension.AspNetZeroRadTool - Menu item clicked with params > loadFromJson: False, loadFromDatabase: False, showAboutForm: True

    @ismcagdas could you kinly advice on when we would have a fix for the issue please?

  • 0
    dmux created

    I had the same issue. The steps from @AuroraBMS worked for me.

  • 0
    ismcagdas created
    Support Team

    Hi @Jorahealth

    AspNet Zero app itself uses .NET Core 3.1 but Power Tools doesn't. You can download .NET Core SDK 2.2.0 here https://dotnet.microsoft.com/download/dotnet-core/2.2